Vulnerability · Published Oct 16, 2026 · Assigned by GitHub_M

CVE-2026-97380MariaDB: GRANT PROXY with empty password incorrectly checks grantor's privileges

High 8.8

In plain English

A high-severity incorrect authorization in server from MariaDB. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.3% (higher than 71% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)1.3%top 29.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

MariaDB server is a community developed fork of MySQL server. From 10.6.1 until 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2, the GRANT PROXY statement treats an IDENTIFIED clause with an empty password as though authentication were not specified, causing it to check the wrong grantor privileges. A low-privileged attacker who can name another account can exploit this authorization error to set that account's password. This issue is fixed in versions 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12mariadbno fix listedDEBIAN-CVE-2026-97380
Debian:13mariadbno fix listedDEBIAN-CVE-2026-97380
Debian:14mariadb1:11.8.9+ds-1DEBIAN-CVE-2026-97380
Ubuntu:24.04:LTSmariadbno fix listedUBUNTU-CVE-2026-97380
Ubuntu:26.04:LTSmariadbno fix listedUBUNTU-CVE-2026-97380
Ubuntu:26.10mariadbno fix listedUBUNTU-CVE-2026-97380
Ubuntu:22.04:LTSmariadb-10.6no fix listedUBUNTU-CVE-2026-97380

Affected products (as reported)

VendorProductVersions
MariaDB server >= 10.6.1, < 10.6.28>= 10.11.1, < 10.11.19>= 11.4.1, < 11.4.13>= 11.8.1, < 11.8.9>= 12.3.1, < 12.3.3>= 13.0.1, < 13.0.2

Weakness: CWE-620, CWE-863 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

References