Vulnerability · Published Jun 17, 2026 · Assigned by openjs

CVE-2026-9679undici vulnerable to HTTP header injection via Set-Cookie percent-decoding

Medium 5.9

In plain English

A medium-severity security flaw in undici from undici. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 17% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.9Medium
Exploit odds (30 days)0.3%top 82.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Impact: undici's cookie parser in parseSetCookie percent-decodes cookie values via qsUnescape, turning encoded sequences like %0D%0A, %00, %3B, and %3D into their literal byte equivalents. RFC 6265 §5.4 does not specify any decoding and browsers do not decode either. Applications that parse a Set-Cookie header and then forward the parsed value into a response header (proxies, middleware, SSR frameworks) become vulnerable to HTTP response header injection: an attacker-controlled upstream can inject arbitrary Set-Cookie, Location, or Cache-Control headers into the application's downstream response, enabling session fixation, open redirect, or cache poisoning. Affected applications are those that use undici's cookie parsing (parseSetCookie, parseCookie, getSetCookies) and forward the parsed cookie value into a response header. This was introduced in undici 7.0.0 via PR #3789. Patches: Upgrade to undici v6.26.0, v7.28.0 or v8.5.0. Workarounds: If upgrade is not immediately possible, do not forward values returned by parseSetCookie/parseCookie/getSetCookies directly into response headers; sanitize the value first to strip or reject CR, LF, NUL, ;, and = bytes.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:13node-undicino fix listedDEBIAN-CVE-2026-9679
Debian:14node-undici8.5.0+dfsg+~cs3.2.0-1DEBIAN-CVE-2026-9679
Ubuntu:24.04:LTSnode-undicino fix listedUBUNTU-CVE-2026-9679
Ubuntu:25.10node-undicino fix listedUBUNTU-CVE-2026-9679
Ubuntu:26.04:LTSnode-undicino fix listedUBUNTU-CVE-2026-9679
Ubuntu:26.10node-undicino fix listedUBUNTU-CVE-2026-9679
npmundici6.27.0GHSA-p88m-4jfj-68fv
npmundici7.28.0GHSA-p88m-4jfj-68fv
npmundici8.5.0GHSA-p88m-4jfj-68fv

Affected products (as reported)

VendorProductVersions
undici undici 0 – before 6.26.07.0.0 – before 7.28.08.0.0 – before 8.5.0

Weakness: CWE-93 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N

References