Vulnerability · Published Jun 17, 2026 · Assigned by openjs
CVE-2026-9675undici WebSocket client vulnerable to denial of service via cumulative fragment bypass
High 7.5
In plain English
A high-severity uncontrolled resource consumption in undici from undici. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 37% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Impact: The undici WebSocket client enforces maxPayloadSize per-frame but does not enforce the cumulative size of fragmented uncompressed messages. A malicious WebSocket server can stream many small fragments that each pass per-frame validation but collectively exceed the configured limit, causing unbounded memory growth in the client process. The result is memory exhaustion and a denial of service. Affected applications are those using the undici WebSocket client (new WebSocket(...)) that can be induced to connect to an attacker-controlled or compromised WebSocket endpoint. This is a regression specific to undici 8.1.0. The 6.25.0 line shipped the equivalent cumulative check from the start and is unaffected. The 7.x line never had the maxPayloadSize feature and is also unaffected. Patches: Upgrade to undici >= 8.5.0. Workarounds: No workaround is available. The fix must be applied through an upgrade.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Ubuntu:24.04:LTS | node-undici | no fix listed | UBUNTU-CVE-2026-9675 |
| Ubuntu:25.10 | node-undici | no fix listed | UBUNTU-CVE-2026-9675 |
| Ubuntu:26.04:LTS | node-undici | no fix listed | UBUNTU-CVE-2026-9675 |
| Ubuntu:26.10 | node-undici | no fix listed | UBUNTU-CVE-2026-9675 |
| npm | undici | 8.5.0 | GHSA-38rv-x7px-6hhq |
Affected products (as reported)
Weakness: CWE-400, CWE-770 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H