Vulnerability · Published Sep 17, 2026 · Assigned by VulnCheck
CVE-2026-92958vm2 before 3.11.7 Denylist Bypass via fs/promises
High 8.5
In plain English
A high-severity privilege mismanagement in vm2 from patriksimek. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 33% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
vm2 through 3.11.6 contains a builtin-module denylist bypass in NodeVM. When the embedder uses the builtin wildcard together with negative entries (e.g. require: { builtin: ['*', '-fs', '-child_process'] }), negative entries are matched by exact module name in lib/builtin.js, so -fs removes only the builtin named fs and does not remove builtin subpaths such as fs/promises. Sandboxed code can therefore call require('fs/promises') or require('node:fs/promises') and reach the promise-based filesystem API despite fs being denied; node: prefix handling is likewise inconsistent (a -node:fs/promises entry does not block require('fs/promises')). Host file creation and writing were confirmed via fsp.writeFile(), and other fs/promises operations (cp, mkdir, rename, rm, rmdir, truncate, read operations, etc.) are also reachable. This issue is fixed in vm2 3.11.7.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | vm2 | 3.11.7 | GHSA-6rh5-qq4q-97xh |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| patriksimek | vm2 | 0 – before 3.11.7 |
Weakness: CWE-269 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:L
References
- GitHub Security Advisory (GHSA-6rh5-qq4q-97xh) vendor-advisory
- VulnCheck Advisory: vm2 before 3.11.7 Denylist Bypass via fs/promises third-party-advisory