Vulnerability · Published Sep 17, 2026 · Assigned by VulnCheck
CVE-2026-92948vm2 3.9.6 through 3.11.5 Sandbox Escape via node:test
Critical 9.9
In plain English
A critical-severity security flaw in vm2 from patriksimek. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 52% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
vm2 versions >= 3.9.6 and <= 3.11.6 are affected by a NodeVM builtin allowlist bypass that permits a sandbox escape on Node.js 24 and newer when the embedder explicitly allows the node:test builtin (e.g. require: { builtin: ['node:test'] }). On Node.js 24+, module.builtinModules exposes the scheme-only key node:test, which is not covered by vm2's family-based DANGEROUS_BUILTINS protection, so it is stored in the generic host-passthrough loader. Because requireImpl() in lib/setup-node-sandbox.js strips a single 'node:' prefix before the builtin lookup, sandbox code calling require('node:node:test') resolves to the stored node:test key and receives a readonly proxy to the host module. Calls to node:test.run() are forwarded to the host implementation, which spawns a separate Node process for process-isolated test execution and passes through attacker-controlled execArgv values; supplying --eval=<JavaScript> therefore executes arbitrary JavaScript in an unrestricted host Node process outside the NodeVM sandbox. Fixed in vm2 3.11.7.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | vm2 | 3.11.7 | GHSA-qhwx-74w5-xhxq |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| patriksimek | vm2 | 3.9.6 – before 3.11.7 |
Weakness: CWE-693 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
References
- GitHub Security Advisory (GHSA-qhwx-74w5-xhxq) vendor-advisory
- VulnCheck Advisory: vm2 3.9.6 through 3.11.5 Sandbox Escape via node:test third-party-advisory