Vulnerability · Published Sep 16, 2026 · Assigned by VulnCheck
CVE-2026-92597Nodemailer before 9.1.0 Email Domain Validation Bypass via RFC 5322 Comment
Medium 6.5
In plain English
A medium-severity security flaw in nodemailer from nodemailer. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 32% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Nodemailer versions >= 6.9.16 and < 9.1.0 mis-parse RFC 5322 comments in email addresses: in lib/addressparser, a comment closed immediately before a non-break character causes the tokenizer to concatenate the atoms surrounding the comment instead of treating the comment as folding whitespace that terminates the domain. A recipient address such as user@good-corp.com(x)evil.com is therefore read by Nodemailer as the single domain good-corp.comevil.com (registrable domain comevil.com, which an attacker can register) and used for both the SMTP envelope (RCPT TO) and the emitted To:/From: headers, while a conformant RFC 5322 parser terminates the domain at the comment and reads good-corp.com. An application that validates the recipient domain with a strict RFC 5322 parser (without inspecting parse defects) or a naive prefix/substring allow-list and then hands the raw address to Nodemailer can be induced to deliver mail to a domain the attacker controls. Fixed in 9.1.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:13 | node-nodemailer | no fix listed | DEBIAN-CVE-2026-92597 |
| Debian:14 | node-nodemailer | 10.0.0+~8.0.1-1 | DEBIAN-CVE-2026-92597 |
| Ubuntu:22.04:LTS | node-nodemailer | no fix listed | UBUNTU-CVE-2026-92597 |
| Ubuntu:24.04:LTS | node-nodemailer | no fix listed | UBUNTU-CVE-2026-92597 |
| Ubuntu:26.04:LTS | node-nodemailer | no fix listed | UBUNTU-CVE-2026-92597 |
| Ubuntu:26.10 | node-nodemailer | no fix listed | UBUNTU-CVE-2026-92597 |
| npm | nodemailer | 9.1.0 | GHSA-cc9r-2j5m-2m83 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| nodemailer | nodemailer | 6.9.16 – before 9.1.0 |
Weakness: CWE-436 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:N
References
- GitHub Security Advisory (GHSA-cc9r-2j5m-2m83) vendor-advisory
- Patch Commit patch
- VulnCheck Advisory: Nodemailer before 9.1.0 Email Domain Validation Bypass via RFC 5322 Comment third-party-advisory