Vulnerability · Published May 20, 2026 · Assigned by AMZN

CVE-2026-9133Arbitrary file read in rabbitmq-aws plugin

High 7.7

In plain English

A high-severity security flaw in RabbitMQ AWS from AWS. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 66% of all known vulnerabilities). Ready-made attack tooling exists: Nuclei.

Severity (CVSS 3.1)7.7High
Exploit odds (30 days)1.1%top 33.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Nuclei

Official description

Active debug code exists in the ARN resolver of amazon-mq rabbitmq-aws before version 0.2.1. A debug ARN scheme (arn:aws-debug:file) accepted by the PUT /api/aws/arn/validate validation endpoint might allow remote authenticated users to perform arbitrary file reads on any file accessible to the RabbitMQ process. To remediate this issue, customers should upgrade to version 0.2.1 of rabbitmq-aws. If RabbitMQ is configured to use TLS for connections, we also recommend rotating any associated private certificate keys.

Affected products (as reported)

VendorProductVersions
AWS RabbitMQ AWS 0.1.0 – through 0.2.0

Weakness: CWE-489 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N

References