Vulnerability · Published Sep 15, 2026 · Assigned by VulDB

CVE-2026-90852luben zstd-jni Dictionary Sharing ZstdCompressCtx.java ZstdCompressCtx.loadDict use after free

High 7.3

In plain English

A high-severity use-after-free in zstd-jni from luben. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 46% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.3High
Exploit odds (30 days)0.5%top 54.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

A vulnerability has been found in luben zstd-jni up to 1.5.7-13. This vulnerability affects the function ZstdCompressCtx.loadDict of the file ZstdCompressCtx.java of the component Dictionary Sharing. Such manipulation leads to use after free. The attack can be executed remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.5.7-14 is able to resolve this issue. The name of the patch is a560131d7834598afd9cea6b7c107bc88e915936. The affected component should be upgraded. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12zstd-jni-javano fix listedDEBIAN-CVE-2026-90852
Debian:13zstd-jni-javano fix listedDEBIAN-CVE-2026-90852
Debian:14zstd-jni-java1.5.7-23+ds-1DEBIAN-CVE-2026-90852
Ubuntu:24.04:LTSzstd-jni-javano fix listedUBUNTU-CVE-2026-90852
Ubuntu:26.04:LTSzstd-jni-javano fix listedUBUNTU-CVE-2026-90852
Ubuntu:26.10zstd-jni-javano fix listedUBUNTU-CVE-2026-90852

Affected products (as reported)

VendorProductVersions
luben zstd-jni 1.5.7-13

Weakness: CWE-416, CWE-119 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:P/RL:O/RC:C

References