Vulnerability · Published Sep 15, 2026 · Assigned by openjs
CVE-2026-90711proxy-addr vulnerable to IP spoofing via IPv4-mapped IPv6 trust subnet
Critical 9.1
In plain English
A critical-severity authentication bypass by spoofing in proxy-addr from proxy-addr. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 18% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
proxy-addr is a Node.js module that determines a request's client address behind trusted reverse proxies, and it backs Express req.ip and req.ips. In versions 1.1.0 through 2.0.7, a trust subnet written in IPv4-mapped IPv6 notation with an IPv4-sized prefix, such as ::ffff:10.0.0.0/8 instead of the correct ::ffff:10.0.0.0/104, is accepted without error but trusts every IPv4 address on the internet rather than the block it names. Because the socket peer then becomes trusted at hop 0, any unauthenticated client can supply an arbitrary X-Forwarded-For header and control the address the application reads, which defeats IP-based access control, rate limiting, geolocation, and audit logging. This is a fail-open regression introduced in version 1.1.0. The issue is fixed in proxy-addr 2.0.8, and users should upgrade to 2.0.8 or later. As a workaround, ensure any IPv4-mapped IPv6 trust subnet uses a prefix length of at least 97, or express the range in plain IPv4 notation.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | node-proxy-addr | no fix listed | DEBIAN-CVE-2026-90711 |
| Debian:13 | node-proxy-addr | no fix listed | DEBIAN-CVE-2026-90711 |
| Debian:14 | node-proxy-addr | 2.0.8+~cs2.3.7-1 | DEBIAN-CVE-2026-90711 |
| Ubuntu:22.04:LTS | node-proxy-addr | no fix listed | UBUNTU-CVE-2026-90711 |
| Ubuntu:24.04:LTS | node-proxy-addr | no fix listed | UBUNTU-CVE-2026-90711 |
| Ubuntu:26.04:LTS | node-proxy-addr | no fix listed | UBUNTU-CVE-2026-90711 |
| Ubuntu:26.10 | node-proxy-addr | no fix listed | UBUNTU-CVE-2026-90711 |
| npm | proxy-addr | 2.0.8 | GHSA-jqcg-44mw-7w3h |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| proxy-addr | proxy-addr | 1.1.0 – before 2.0.8 |
Weakness: CWE-290, CWE-348, CWE-697 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N