Vulnerability · Published Sep 11, 2026 · Assigned by VulnCheck
CVE-2026-89259Hugo before v0.165.0 Insufficient Permission Restriction via TailwindCSS
Critical 9.8
In plain English
A critical-severity security flaw in hugo from gohugoio. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Hugo is a static site generator. From v0.161.0, Hugo executes Node tools under Node's permission model, but TailwindCSS — included in the default security.exec.allow list — requires a highly permissive configuration (--allow-addons, --allow-child-process, --allow-worker). As a result, the restrictions intended by the fix for GHSA-x597-9fr4-5857 could still be bypassed, allowing a Node tool invoked during a build to read and write files outside the project's working directory. Affected versions are those after v0.43; the issue was fixed in v0.165.0 by removing tailwindcss from the default security.exec.allow list. Users who do not use TailwindCSS, or who only build trusted sites, are not affected. As a workaround, users can define a restrictive security.exec.allow list in hugo.toml.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:14 | hugo | 0.165.0-1 | DEBIAN-CVE-2026-89259 |
| Ubuntu:22.04:LTS | hugo | no fix listed | UBUNTU-CVE-2026-89259 |
| Ubuntu:26.04:LTS | hugo | no fix listed | UBUNTU-CVE-2026-89259 |
| Ubuntu:26.10 | hugo | no fix listed | UBUNTU-CVE-2026-89259 |
Affected products (as reported)
Weakness: CWE-250 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
References
- GitHub Security Advisory (GHSA-vrm6-x8vp-mv2r) vendor-advisory
- VulnCheck Advisory: Hugo before v0.165.0 Insufficient Permission Restriction via TailwindCSS third-party-advisory