Vulnerability · Published Sep 11, 2026 · Assigned by openjs
CVE-2026-87908multiparty vulnerable to Denial of Service via unbounded part-header accumulation
High 7.5
In plain English
A high-severity uncontrolled resource consumption in multiparty from multiparty. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 44% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
multiparty is a Node.js library for parsing multipart/form-data request bodies. In versions from 2.1.0 up to but not including 4.3.1, the parser does not bound the amount of memory used while accumulating the headers of a single multipart part. An unauthenticated attacker can send a single request whose part carries a very large volume of header bytes, forcing the parser to buffer all of them and exhausting the process memory, which crashes the server. This is a denial of service with no confidentiality or integrity impact. The issue is fixed in multiparty 4.3.1, which caps the size of the accumulated part headers. Users should upgrade to multiparty 4.3.1 or later.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | node-multiparty | no fix listed | DEBIAN-CVE-2026-87908 |
| Debian:13 | node-multiparty | no fix listed | DEBIAN-CVE-2026-87908 |
| Debian:14 | node-multiparty | 4.3.1+~4.2.1-1 | DEBIAN-CVE-2026-87908 |
| Ubuntu:22.04:LTS | node-multiparty | no fix listed | UBUNTU-CVE-2026-87908 |
| Ubuntu:24.04:LTS | node-multiparty | no fix listed | UBUNTU-CVE-2026-87908 |
| Ubuntu:26.04:LTS | node-multiparty | no fix listed | UBUNTU-CVE-2026-87908 |
| Ubuntu:26.10 | node-multiparty | no fix listed | UBUNTU-CVE-2026-87908 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| multiparty | multiparty | 2.1.0 – before 4.3.1 |
Weakness: CWE-400, CWE-770 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H