Vulnerability · Published Oct 15, 2026 · Assigned by openjs
CVE-2026-87018undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation
High 7.5
In plain English
A high-severity security flaw in undici from undici. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 8% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
undici is an HTTP client library for Node.js. In versions 4.2.1 through 6.29.0, 7.0.0 through 7.30.0, and 8.0.0 through 8.12.1, the client process crashes when a TLS 1.2 server renegotiates after the connection is established and presents a different, CA-trusted certificate whose hostname does not match the requested host. Node.js re-runs hostname verification on the renegotiated handshake and destroys the socket with a certificate-altname error, but undici's established-socket error handler asserted that this error code could never occur, so the peer-controlled error became an uncaught assertion that terminates the Node.js process, affecting both the HTTP/1.1 and HTTP/2 paths. A malicious or compromised HTTPS endpoint reached through undici or the global fetch() can crash the client with a single server-initiated renegotiation, taking down all in-flight requests and background work in the process, and exploitation needs no CA compromise because the attacker controls the endpoint and can present two ordinary valid certificates. Only TLS 1.2 is affected, since TLS 1.3 does not support renegotiation. The issue is fixed in undici 6.29.1, 7.30.1, and 8.12.2, and users should upgrade to one of those versions or later. As a workaround, restrict outbound connections to TLS 1.3 so renegotiation cannot occur, when the target endpoints support it.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | node-undici | no fix listed | DEBIAN-CVE-2026-87018 |
| Debian:13 | node-undici | no fix listed | DEBIAN-CVE-2026-87018 |
| Debian:14 | node-undici | 8.12.2+dfsg+~cs3.2.3-1 | DEBIAN-CVE-2026-87018 |
| Ubuntu:24.04:LTS | node-undici | no fix listed | UBUNTU-CVE-2026-87018 |
| Ubuntu:26.04:LTS | node-undici | no fix listed | UBUNTU-CVE-2026-87018 |
| Ubuntu:26.10 | node-undici | no fix listed | UBUNTU-CVE-2026-87018 |
| npm | undici | 7.30.1 | GHSA-qrxm-fqhp-jwvm |
| npm | undici | 8.12.2 | GHSA-qrxm-fqhp-jwvm |
| npm | undici | 6.29.1 | GHSA-qrxm-fqhp-jwvm |
Affected products (as reported)
Weakness: CWE-248, CWE-617 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H