Vulnerability · Published Sep 10, 2026 · Assigned by AMZN
CVE-2026-85228Integer overflow in tensor buffer validation in Deep Java Library
Critical 9.1
In plain English
A critical-severity integer overflow in Deep Java Library from Amazon. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 46% of all known vulnerabilities).
Official description
An integer overflow in the tensor buffer validation component in Amazon Deep Java Library (DJL) from 0.13.0 through 0.36.0 on all platforms might allow a remote unauthenticated actor to obtain information from adjacent process memory or cause a denial of service via a crafted tensor payload. To remediate this issue, users should upgrade to version 0.37.0 or above.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Amazon | Deep Java Library | 0.13.0 – through 0.36.0 |
Weakness: CWE-190 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H