Vulnerability · Published Sep 1, 2026 · Assigned by GitHub_M

CVE-2026-84308phpseclib — non-constant-time X25519 scalar multiplication permits full private-key recovery

Medium 6.3

In plain English

A medium-severity security flaw in phpseclib from phpseclib. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 26% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.3Medium
Exploit odds (30 days)0.3%top 74.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

phpseclib is a PHP secure communications library. Prior to 3.0.57 and 4.0.1, pure-PHP X25519 scalar multiplication in phpseclib/Math/PrimeField/Integer.php performs data-dependent conditional modular reductions in add() and subtract(). During the Montgomery ladder in phpseclib/Crypt/EC/BaseCurves/Montgomery.php, the reduction behavior of each step depends on the secret scalar prefix, creating per-step timing and libgmp call-count observations that can reveal a reused 251-bit clamped private scalar. The phpseclib/Crypt/EC/Formats/Keys/MontgomeryPrivate.php derivation path invokes the pure-PHP multiplication without a native-engine check, while phpseclib/Crypt/EC/Formats/Keys/PKCS8.php reaches it when ext-sodium is unavailable. Exploitation requires a reused or long-lived X25519 private key, knowledge of the corresponding public key, execution of the pure-PHP path, and a local observer capable of resolving individual ladder steps or libgmp entry-point calls. Ephemeral X25519 keys, including phpseclib's normal SSH exchange path, are not affected. Recovery of the scalar permanently compromises operations that reuse that key. This issue is fixed in versions 3.0.57 and 4.0.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12php-phpseclib3no fix listedDEBIAN-CVE-2026-84308
Debian:13php-phpseclib3no fix listedDEBIAN-CVE-2026-84308
Debian:14php-phpseclib33.0.57-1DEBIAN-CVE-2026-84308
Debian:14php-phpseclib44.0.1-1DEBIAN-CVE-2026-84308
Packagistphpseclib/phpseclib3.0.57GHSA-q97c-8qh3-fpc6
Packagistphpseclib/phpseclib4.0.1GHSA-q97c-8qh3-fpc6
Ubuntu:26.10php-phpseclibno fix listedUBUNTU-CVE-2026-84308
Ubuntu:24.04:LTSphp-phpseclib3no fix listedUBUNTU-CVE-2026-84308
Ubuntu:26.04:LTSphp-phpseclib3no fix listedUBUNTU-CVE-2026-84308
Ubuntu:26.10php-phpseclib3no fix listedUBUNTU-CVE-2026-84308
Ubuntu:22.04:LTSphpseclibno fix listedUBUNTU-CVE-2026-84308
Ubuntu:26.10phpseclibno fix listedUBUNTU-CVE-2026-84308

Affected products (as reported)

VendorProductVersions
phpseclib phpseclib < 3.0.57>= 4.0.0, < 4.0.1

Weakness: CWE-208, CWE-385 · Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N

References