Vulnerability · Published Sep 1, 2026 · Assigned by GitHub_M
CVE-2026-83608xmldom: DocType `name` Injection Bypasses requireWellFormed
High 8.7
In plain English
A high-severity security flaw in xmldom from xmldom. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 49% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
xmldom is a pure JavaScript W3C standard-based (XML DOM Level 2 Core) DOMParser and XMLSerializer module. Prior to @xmldom/xmldom versions 0.8.15 and 0.9.12, and in xmldom version 0.6.0 and earlier, the DOCUMENT_TYPE_NODE branch in lib/dom.js validates publicId, systemId, and internalSubset under requireWellFormed: true but emits DocumentType.name verbatim. A name containing > or whitespace can terminate the <!DOCTYPE ...> declaration and inject sibling markup; the value can be supplied through createDocumentType() on the 0.8.x and unscoped lines or through a direct DocumentType.name property write on every affected line. The default path and legacy creation-time behavior remain permissive, while the vulnerable strict path fails to enforce an XML Name. This issue is fixed in @xmldom/xmldom versions 0.8.15 and 0.9.12; no fixed version is available for xmldom.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | node-xmldom | no fix listed | DEBIAN-CVE-2026-83608 |
| Debian:13 | node-xmldom | no fix listed | DEBIAN-CVE-2026-83608 |
| Debian:14 | node-xmldom | 0.9.12-1 | DEBIAN-CVE-2026-83608 |
| Ubuntu:22.04:LTS | node-xmldom | no fix listed | UBUNTU-CVE-2026-83608 |
| Ubuntu:24.04:LTS | node-xmldom | no fix listed | UBUNTU-CVE-2026-83608 |
| Ubuntu:26.04:LTS | node-xmldom | no fix listed | UBUNTU-CVE-2026-83608 |
| Ubuntu:26.10 | node-xmldom | no fix listed | UBUNTU-CVE-2026-83608 |
| npm | @xmldom/xmldom | 0.8.15 | GHSA-27p8-2357-5qqv |
| npm | @xmldom/xmldom | 0.9.12 | GHSA-27p8-2357-5qqv |
| npm | xmldom | no fix listed | GHSA-27p8-2357-5qqv |
Affected products (as reported)
Weakness: CWE-91 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
References
- https://github.com/xmldom/xmldom/security/advisories/GHSA-27p8-2357-5qqv x_refsource_CONFIRM
- https://github.com/xmldom/xmldom/pull/1071 x_refsource_MISC
- https://github.com/xmldom/xmldom/pull/1072 x_refsource_MISC
- https://github.com/xmldom/xmldom/commit/57aec90ac57b4408ae7c5d1746bf2a693b5ed90e x_refsource_MISC
- https://github.com/xmldom/xmldom/commit/85f12eb4d14b44de33216cfb72b50af4d24e9fdd x_refsource_MISC
- https://github.com/xmldom/xmldom/releases/tag/0.8.15 x_refsource_MISC
- https://github.com/xmldom/xmldom/releases/tag/0.9.12 x_refsource_MISC