Vulnerability · Published Aug 28, 2026 · Assigned by VulnCheck
CVE-2026-82259SvelteKit 2.49.0 before 2.53.3 Denial of Service via form
High 7.5
In plain English
A high-severity unsafe deserialization in kit from sveltejs. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 45% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
SvelteKit versions from 2.49.0 through 2.53.2 (fixed in 2.53.3) contain a deserialization expansion issue in the experimental form remote function. When an application enables experimental.remoteFunctions and uses the form function to process the files array without validating files.length or individual file sizes, an attacker can submit relatively small inputs that expand into very large file arrays, leading to expensive processing and denial of service.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @sveltejs/kit | 2.53.3 | GHSA-fpg4-jhqr-589c |
Affected products (as reported)
Weakness: CWE-502 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
References
- GitHub Security Advisory (GHSA-fpg4-jhqr-589c) vendor-advisory
- VulnCheck Advisory: SvelteKit 2.49.0 before 2.53.3 Denial of Service via form third-party-advisory