Vulnerability · Published Aug 27, 2026 · Assigned by VulnCheck
CVE-2026-81697openssl_encrypt before 1.4.9 KDF Downgrade via CWD-relative Configuration
Medium 5.5
In plain English
A medium-severity security flaw in openssl_encrypt from jahlives. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 11% of all known vulnerabilities).
Official description
openssl_encrypt (pip package openssl-encrypt) versions <= 1.4.8 contain a CWD-relative configuration file resolution flaw in crypt_settings.py, where CONFIG_FILE (originally the absolute per-user path ~/.crypt_settings.json) is reassigned at line 84 to the bare relative name 'crypt_settings.json'. As a result, the legacy Tk GUI's SettingsTab reads and writes KDF settings from crypt_settings.json in the process launch (current working) directory instead of the user's home directory. An attacker who plants a malicious crypt_settings.json (e.g. sha256:1 with all memory-hard KDFs disabled) can silently downgrade encryption performed in that GUI session to roughly one hash round, bypassing the weak-KDF preflight and enabling offline brute-force attacks against the resulting ciphertext. Fixed in 1.4.9.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| jahlives | openssl_encrypt | 0 – before 1.4.9 |
Weakness: CWE-426 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
References
- GitHub Security Advisory (GHSA-7j2v-g84w-m75v) vendor-advisory
- VulnCheck Advisory: openssl_encrypt before 1.4.9 KDF Downgrade via CWD-relative Configuration third-party-advisory