Vulnerability · Published Aug 25, 2026 · Assigned by VulnCheck
CVE-2026-79667Ech0 before 4.4.3 Authentication Bypass via Scope Enforcement
High 7.6
In plain English
A high-severity security flaw in Ech0 from lin-snow. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 25% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Ech0 version 4.3.4 and earlier fails to reliably enforce scoped access token (least-privilege) restrictions on several privileged admin routes. Multiple privileged endpoints (e.g., /api/inbox, /api/panel/comments, /api/backup/export) omit scope checks and authorize based only on the user's admin role, and the backup export handler discards token scope metadata entirely. An attacker holding a deliberately limited (low-scope) admin access token can reach broader privileged functionality than intended, including reading the inbox and exporting a full database backup ZIP archive. Fixed in 4.4.3.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/lin-snow/ech0 | 4.3.5 | GHSA-4h9q-p5j4-xvvh |
| Go | github.com/lin-snow/ech0 | no fix listed | GO-2026-5123 |
Affected products (as reported)
Weakness: CWE-285 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:L
References
- GitHub Security Advisory (GHSA-4h9q-p5j4-xvvh) vendor-advisory
- VulnCheck Advisory: Ech0 before 4.4.3 Authentication Bypass via Scope Enforcement third-party-advisory