Vulnerability · Published Aug 25, 2026 · Assigned by VulnCheck
CVE-2026-78683NLTK before 3.10.0 Remote Code Execution via Unsafe Pickle Deserialization
Critical 9.6
In plain English
A critical-severity unsafe deserialization in nltk from nltk. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 44% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
NLTK before 3.10.0 (affected versions <=3.9.4) contains an unsafe pickle deserialization vulnerability in the TransitionParser.parse() method (nltk/parse/transitionparser.py). The method calls pickle_load() with the default restricted=False, routing deserialization through WarningUnpickler, which does not override find_class() and therefore permits arbitrary class resolution. When an application loads an attacker-crafted model file, embedded pickle gadget chains execute arbitrary Python code with the privileges of the user running the application. NLTK provides a RestrictedUnpickler for safe deserialization, but it is not used by production code paths. Fixed in 3.10.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | nltk | no fix listed | DEBIAN-CVE-2026-78683 |
| Debian:13 | nltk | no fix listed | DEBIAN-CVE-2026-78683 |
| Debian:14 | nltk | 3.10.0-1 | DEBIAN-CVE-2026-78683 |
| PyPI | nltk | 3.10.0 | GHSA-rhp5-r9x4-f5g2 |
| PyPI | nltk | 3.10.0 | PYSEC-2026-3734 |
Affected products (as reported)
Weakness: CWE-502 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
References
- GitHub Security Advisory (GHSA-rhp5-r9x4-f5g2) vendor-advisory
- VulnCheck Advisory: NLTK before 3.10.0 Remote Code Execution via Unsafe Pickle Deserialization third-party-advisory