Vulnerability · Published May 4, 2026 · Assigned by openjs
CVE-2026-7768@fastify/accepts-serializer vulnerable to Denial of Service via Unbounded Accept Header Cache Growth
High 7.5
In plain English
A high-severity resource allocation without limits in @fastify/accepts-serializer from @fastify/accepts-serializer. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 21% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
@fastify/accepts-serializer cached serializer-selection results keyed by the request Accept header without a size limit or eviction policy. A remote unauthenticated client could send many distinct but matching Accept header variants to make the cache grow unbounded, eventually exhausting the Node.js heap and crashing the process. Versions <= 6.0.3 are affected. Update to 6.0.4 or later, which bounds the cache via an LRU with a default size of 100 entries, configurable through the new cacheSize plugin option.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @fastify/accepts-serializer | 6.0.4 | GHSA-qxhc-wx3p-2wmg |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| @fastify/accepts-serializer | @fastify/accepts-serializer | 0 – before 6.0.4 |
Weakness: CWE-770 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H