Vulnerability · Published Aug 24, 2026 · Assigned by GitHub_M

CVE-2026-77635CakePHP: FunctionsBuilder::jsonValue() vulerable to SQL injection with PostgresDriver

Critical 9.2

In plain English

A critical-severity SQL injection in cakephp from cakephp. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 43% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)9.2Critical
Exploit odds (30 days)0.5%top 57.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

CakePHP is a rapid development framework for PHP. Prior to versions 5.1.10, 5.2.15, and 5.3.7 on their respective release lines, FunctionsBuilder::jsonValue() with PostgresDriver is vulnerable to SQL injection when user-controlled data is supplied to the jsonPath parameter. This issue is fixed in versions 5.1.10, 5.2.15, and 5.3.7.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistcakephp/cakephp5.1.10GHSA-fxf7-vhh8-7vpq
Packagistcakephp/cakephp5.3.7GHSA-fxf7-vhh8-7vpq
Packagistcakephp/cakephp5.2.15GHSA-fxf7-vhh8-7vpq
Packagistcakephp/database5.3.7GHSA-fxf7-vhh8-7vpq
Packagistcakephp/database5.2.15GHSA-fxf7-vhh8-7vpq
Packagistcakephp/database5.1.10GHSA-fxf7-vhh8-7vpq
Ubuntu:22.04:LTScakephpno fix listedUBUNTU-CVE-2026-77635

Affected products (as reported)

VendorProductVersions
cakephp cakephp >= 5.1.0, < 5.1.10>= 5.2.0, < 5.2.15>= 5.3.0, < 5.3.7
cakephp cakephp/database >= 5.1.0, < 5.1.10>= 5.2.0, < 5.2.15>= 5.3.0, < 5.3.7

Weakness: CWE-89 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N

References