Vulnerability · Published Oct 1, 2026 · Assigned by GitHub_M

CVE-2026-77387geopy: Regular Expression Denial of Service (ReDoS) in geopy.Point

Medium 4.0

In plain English

A medium-severity regular-expression denial of service in geopy from geopy. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 10% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.0Medium
Exploit odds (30 days)0.2%top 89.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

geopy is a geocoding library for Python. Prior to 2.5.0, geopy.Point and Point.from_string() can spend excessive CPU time due to inefficient regular-expression behavior when an application passes a long malformed coordinate string without the 256-character input limit used by the fix. Geocoder reverse methods also reach the vulnerable parsing path when called with string inputs. Repeated attacker-controlled requests can cause a denial of service, while the numeric Point constructor is unaffected. This issue is fixed in version 2.5.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12geopyno fix listedDEBIAN-CVE-2026-77387
Debian:13geopyno fix listedDEBIAN-CVE-2026-77387
Debian:14geopyno fix listedDEBIAN-CVE-2026-77387
PyPIgeopy2.5.0GHSA-mhvh-fq92-pfmr
PyPIgeopy2.5.0PYSEC-2026-4218
Ubuntu:22.04:LTSgeopyno fix listedUBUNTU-CVE-2026-77387
Ubuntu:24.04:LTSgeopyno fix listedUBUNTU-CVE-2026-77387
Ubuntu:26.04:LTSgeopyno fix listedUBUNTU-CVE-2026-77387
Ubuntu:26.10geopyno fix listedUBUNTU-CVE-2026-77387

Affected products (as reported)

VendorProductVersions
geopy geopy < 2.5.0

Weakness: CWE-1333 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

References