Vulnerability · Published May 4, 2026 · Assigned by VulDB

CVE-2026-7735osrg GoBGP AIGP Attribute bgp.go PathAttributeAigp.DecodeFromBytes buffer overflow

High 7.3

In plain English

A high-severity buffer overflow in GoBGP from osrg. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 30% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.3High
Exploit odds (30 days)0.4%top 69.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

A vulnerability was found in osrg GoBGP up to 4.3.0. Affected is the function PathAttributeAigp.DecodeFromBytes of the file pkg/packet/bgp/bgp.go of the component AIGP Attribute Parser. Performing a manipulation results in buffer overflow. It is possible to initiate the attack remotely. Upgrading to version 4.4.0 is able to address this issue. The patch is named 51ad1ada06cb41ce47b7066799981816f50b7ced. The affected component should be upgraded.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12gobgpno fix listedDEBIAN-CVE-2026-7735
Debian:13gobgpno fix listedDEBIAN-CVE-2026-7735
Debian:14gobgp4.4.0-1DEBIAN-CVE-2026-7735
Ubuntu:25.10gobgpno fix listedUBUNTU-CVE-2026-7735

Affected products (as reported)

VendorProductVersions
osrg GoBGP 4.04.14.24.3.0

Weakness: CWE-120, CWE-119 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:X/RL:O/RC:C

References