Vulnerability · Published May 4, 2026 · Assigned by VulDB

CVE-2026-7734osrg GoBGP SRv6 L3 Service prefix_sid.go SRv6L3ServiceAttribute.DecodeFromBytes denial of service

Medium 5.3

In plain English

A medium-severity security flaw in GoBGP from osrg. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 40% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)0.5%top 59.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

A vulnerability has been found in osrg GoBGP up to 4.3.0. This impacts the function SRv6L3ServiceAttribute.DecodeFromBytes of the file pkg/packet/bgp/prefix_sid.go of the component SRv6 L3 Service. Such manipulation of the argument data leads to denial of service. The attack may be performed from remote. Upgrading to version 4.4.0 will fix this issue. The name of the patch is f9f7b55ec258e514be0264871fa645a2c3edad11. You should upgrade the affected component.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12gobgpno fix listedDEBIAN-CVE-2026-7734
Debian:13gobgpno fix listedDEBIAN-CVE-2026-7734
Debian:14gobgp4.4.0-1DEBIAN-CVE-2026-7734
Gogithub.com/osrg/gobgp/v44.4.0GHSA-vm3g-8xwv-mxfp
Gogithub.com/osrg/gobgp/v44.4.0GO-2026-5665
Ubuntu:25.10gobgpno fix listedUBUNTU-CVE-2026-7734

Affected products (as reported)

VendorProductVersions
osrg GoBGP 4.04.14.24.3.0

Weakness: CWE-404 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L/E:X/RL:O/RC:C

References