Vulnerability · Published Sep 17, 2026 · Assigned by GitHub_M

CVE-2026-77281Caddy: rewrite placeholder re-expansion

Medium 6.5

In plain English

A medium-severity code injection in caddy from caddyserver. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)0.5%top 57.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Caddy is an extensible server platform that uses TLS by default. In version 2.11.3 and earlier, three configuration-dependent weaknesses affect the handler and placeholder layer. In modules/caddyhttp/rewrite/rewrite.go, Rewrite.Rewrite() can pass attacker-controlled replacement bytes through buildQueryString for a second placeholder expansion when a rewrite URI ends with a literal question mark, allowing injected environment or request-variable placeholders to disclose data and, when the file provider is registered, allowing injected file placeholders to disclose readable files. The issue is fixed in version 2.11.4.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12caddy2.6.2-5+deb12u1DEBIAN-CVE-2026-77281
Debian:13caddyno fix listedDEBIAN-CVE-2026-77281
Debian:14caddy2.11.4-1DEBIAN-CVE-2026-77281
Gogithub.com/caddyserver/caddy/v22.11.4GHSA-j8px-rmrx-76h9
Gogithub.com/caddyserver/caddy/v22.11.4GO-2026-6512

Affected products (as reported)

VendorProductVersions
caddyserver caddy < 2.11.4

Weakness: CWE-94, CWE-178, CWE-770 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L

References