Vulnerability · Published Aug 24, 2026 · Assigned by GitHub_M

CVE-2026-76816Netty: MQTT Topic Name and Client ID Validation Bypass

Low 3.5

In plain English

A low-severity improper input validation in netty from netty. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 7% of all known vulnerabilities).

Severity (CVSS 3.1)3.5Low
Exploit odds (30 days)0.2%top 93.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Netty is an asynchronous, event-driven network application framework. Prior to versions 4.1.137.Final and 4.2.17.Final, MqttEncoder does not validate client identifiers, will topics, usernames, and PUBLISH topic names before encoding, allowing prohibited null bytes in MQTT UTF-8 string fields and potentially causing routing, access-control, or identity mismatches in downstream brokers. The vulnerability is exploitable when an application uses Netty's MQTT encoder to construct messages from user-controlled input. This issue is fixed in versions 4.1.137.Final and 4.2.17.Final.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12nettyno fix listedDEBIAN-CVE-2026-76816
Debian:13nettyno fix listedDEBIAN-CVE-2026-76816
Debian:14nettyno fix listedDEBIAN-CVE-2026-76816
Ubuntu:26.10nettyno fix listedUBUNTU-CVE-2026-76816

Affected products (as reported)

VendorProductVersions
netty netty >= 4.2.0.Final, < 4.1.137.Final< 4.1.137.Final

Weakness: CWE-20, CWE-626 · Vector: CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

References