Vulnerability · Published Aug 24, 2026 · Assigned by GitHub_M
CVE-2026-76098Mistune has Denial of Service — RecursionError via Excessive Emphasis Markers in Markdown
High 7.5
In plain English
A high-severity security flaw in mistune from lepture. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Mistune is a Python Markdown parser with renderers and plugins. Versions 3.3.0 through 3.3.2 are vulnerable to DoS through deeply nested tokens. HTML rendering creates deeply nested emphasis tokens from consecutive asterisk characters, and recursive rendering in HTMLRenderer.render_token() can exceed Python's recursion limit and raise RecursionError, allowing crafted Markdown to crash a parsing process. This issue is fixed in version 3.3.3
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | mistune | no fix listed | DEBIAN-CVE-2026-76098 |
| Debian:13 | mistune | no fix listed | DEBIAN-CVE-2026-76098 |
| Debian:14 | mistune | no fix listed | DEBIAN-CVE-2026-76098 |
| PyPI | mistune | 3.3.3 | GHSA-6m44-fpc8-c3rq |
| PyPI | mistune | 3.3.3 | PYSEC-2026-3863 |
| Ubuntu:22.04:LTS | mistune | no fix listed | UBUNTU-CVE-2026-76098 |
| Ubuntu:24.04:LTS | mistune | no fix listed | UBUNTU-CVE-2026-76098 |
| Ubuntu:26.04:LTS | mistune | no fix listed | UBUNTU-CVE-2026-76098 |
| Ubuntu:26.10 | mistune | no fix listed | UBUNTU-CVE-2026-76098 |
Affected products (as reported)
Weakness: CWE-674 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
References
- https://github.com/lepture/mistune/security/advisories/GHSA-6m44-fpc8-c3rq x_refsource_CONFIRM
- https://github.com/lepture/mistune/commit/0938fb7 x_refsource_MISC