Vulnerability · Published Aug 24, 2026 · Assigned by openjs

CVE-2026-75975fast-uri vulnerable to server-side request forgery via malformed IPv6 normalization

High 7.5

In plain English

A high-severity improper input validation in fast-uri from fast-uri. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 13% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.2%top 87.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

fast-uri is a URI parser for Node.js. Its custom parser for bracketed IPv6 literals does not validate the complete IPv6 grammar, so invalid trailing text in an authority can be silently discarded and a malformed attacker-controlled host is turned into a different valid IPv6 destination. For example, a bracketed literal with invalid trailing characters is normalized to the unspecified address, which a Node HTTP client then connects to a local service over loopback, and other malformed literals collapse to private-range addresses. No error is set on the parsed result, so an application checking the error field cannot detect the rewrite. An application that normalizes untrusted URLs before outbound requests, redirects, proxy routing, or address-policy enforcement can be redirected to a local or private IPv6 target, giving a server-side request forgery and address-policy bypass primitive. The affected versions are 2.3.1 up to but not including 2.4.5, 3.0.0 up to but not including 3.1.6, and 4.0.0 up to but not including 4.1.3. The issue is fixed in 2.4.5, 3.1.6, and 4.1.3, which validate bracketed IP literals against the full grammar and mark malformed literals as authority errors. Users should upgrade to a patched version.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:10cockpit-image-builder94.4-1.el10_2ALSA-2026:71543
Debian:13node-ajvno fix listedDEBIAN-CVE-2026-75975
Debian:14node-ajv8.20.0~ds+~cs7.1.4-1DEBIAN-CVE-2026-75975
Rocky Linux:10cockpit-image-builder0:94.4-1.el10_2RLSA-2026:71543
Ubuntu:22.04:LTSnode-ajvno fix listedUBUNTU-CVE-2026-75975
Ubuntu:24.04:LTSnode-ajvno fix listedUBUNTU-CVE-2026-75975
Ubuntu:26.04:LTSnode-ajvno fix listedUBUNTU-CVE-2026-75975
Ubuntu:26.10node-ajvno fix listedUBUNTU-CVE-2026-75975
npmfast-uri2.4.5GHSA-f65p-4m7j-42xc
npmfast-uri3.1.6GHSA-f65p-4m7j-42xc
npmfast-uri4.1.3GHSA-f65p-4m7j-42xc

Affected products (as reported)

VendorProductVersions
fast-uri fast-uri 2.3.1 – before 2.4.53.0.0 – before 3.1.64.0.0 – before 4.1.3

Weakness: CWE-20, CWE-918 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

References