Vulnerability · Published Sep 23, 2026 · Assigned by apache

CVE-2026-75973Apache Tomcat: Cross-context authentication mix-up with Jakarta Authentication configured

High 7.3

In plain English

A high-severity improper authentication in Apache Tomcat from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 44% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.3High
Exploit odds (30 days)0.5%top 55.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Improper Authentication vulnerability in Apache Tomcat. When Jakarta Authentication was configured with SimpleAuthConfigProvider as the default provider and multiple web application used that provider, the realm for the first web application to authenticate a request would be used for all web applications. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.25, from 10.1.0-M1 through 10.1.59, from 9.0.0.M4 through 9.0.121. The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.26, 10.1.60, 9.0.122, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12tomcat10no fix listedDEBIAN-CVE-2026-75973
Debian:13tomcat10no fix listedDEBIAN-CVE-2026-75973
Debian:14tomcat1010.1.60-1DEBIAN-CVE-2026-75973
Debian:13tomcat11no fix listedDEBIAN-CVE-2026-75973
Debian:14tomcat11no fix listedDEBIAN-CVE-2026-75973
Debian:12tomcat99.0.70-2DEBIAN-CVE-2026-75973
Debian:13tomcat99.0.70-2DEBIAN-CVE-2026-75973
Debian:14tomcat99.0.70-2DEBIAN-CVE-2026-75973
Ubuntu:24.04:LTStomcat10no fix listedUBUNTU-CVE-2026-75973
Ubuntu:26.04:LTStomcat10no fix listedUBUNTU-CVE-2026-75973
Ubuntu:26.10tomcat10no fix listedUBUNTU-CVE-2026-75973
Ubuntu:26.04:LTStomcat11no fix listedUBUNTU-CVE-2026-75973
Ubuntu:26.10tomcat11no fix listedUBUNTU-CVE-2026-75973
Ubuntu:24.04:LTStomcat9no fix listedUBUNTU-CVE-2026-75973
Ubuntu:26.04:LTStomcat9no fix listedUBUNTU-CVE-2026-75973
Ubuntu:26.10tomcat9no fix listedUBUNTU-CVE-2026-75973

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Tomcat 11.0.0-M1 – through 11.0.2510.1.0-M1 – through 10.1.599.0.0.M4 – through 9.0.1218.5.0 – through 8.5.100

Weakness: CWE-287 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

References