Vulnerability · Published Aug 24, 2026 · Assigned by openjs
CVE-2026-75899fast-uri vulnerable to server-side request forgery via repeated hostname percent-decoding
High 7.5
In plain English
A high-severity server-side request forgery in fast-uri from fast-uri. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 13% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
fast-uri is a URI parser for Node.js. It decodes percent escapes in a hostname during parsing and then decodes the parsed hostname a second time during authority recomposition, so a single call to normalize or resolve can turn nested percent-encoded input into a different network destination such as a loopback hostname or address. For example, a doubly encoded host that spells out a loopback name decodes to that live host in one operation, which contradicts RFC 3986 section 2.4 that an implementation must not decode the same string more than once. An application that normalizes or resolves an untrusted HTTP-family URI before outbound routing, redirect validation, or a host-policy check can receive a destination different from the one the original encoded host represented, giving a server-side request forgery and host-policy bypass primitive. This is an incomplete-fix variant of CVE-2026-6322. The affected versions are 2.4.1 up to but not including 2.4.5, 3.1.2 up to but not including 3.1.6, and 4.0.0 up to but not including 4.1.3. The issue is fixed in 2.4.5, 3.1.6, and 4.1.3, which normalize percent escapes once and preserve encoded percent signs. Users should upgrade to a patched version.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:10 | cockpit-image-builder | 94.4-1.el10_2 | ALSA-2026:71543 |
| Debian:13 | node-ajv | no fix listed | DEBIAN-CVE-2026-75899 |
| Debian:14 | node-ajv | 8.20.0~ds+~cs7.1.4-1 | DEBIAN-CVE-2026-75899 |
| Rocky Linux:10 | cockpit-image-builder | 0:94.4-1.el10_2 | RLSA-2026:71543 |
| Ubuntu:22.04:LTS | node-ajv | no fix listed | UBUNTU-CVE-2026-75899 |
| Ubuntu:24.04:LTS | node-ajv | no fix listed | UBUNTU-CVE-2026-75899 |
| Ubuntu:26.04:LTS | node-ajv | no fix listed | UBUNTU-CVE-2026-75899 |
| Ubuntu:26.10 | node-ajv | no fix listed | UBUNTU-CVE-2026-75899 |
| npm | fast-uri | 2.4.5 | GHSA-fph4-wmhf-6fwf |
| npm | fast-uri | 3.1.6 | GHSA-fph4-wmhf-6fwf |
| npm | fast-uri | 4.1.3 | GHSA-fph4-wmhf-6fwf |
Affected products (as reported)
Weakness: CWE-174, CWE-918 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N