Vulnerability · Published Aug 18, 2026 · Assigned by VulnCheck

CVE-2026-75858CodeWhale rlm_eval before 0.8.64 Remote Code Execution

High 7.8

In plain English

A high-severity code injection in CodeWhale from Hmbown. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 30% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.8High
Exploit odds (30 days)0.4%top 69.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

CodeWhale (packages codewhale / codewhale-tui) versions >= 0.8.41 and < 0.8.64 contain a remote code execution vulnerability in the rlm_eval tool. The tool's approval_requirement() returns ApprovalRequirement::Auto, which the engine treats as 'never prompt,' causing arbitrary model-supplied Python code to run in a python3 interpreter without consulting the user's configured --approval-policy and without any approval prompt or audit step. An attacker can induce the agent to execute arbitrary code via prompt injection in untrusted content the agent reads (a web page, fetched URL, repository file, or MCP tool result); the companion rlm_open tool can stage such content. Code runs on the user's machine at the user's privilege level. Fixed in 0.8.64.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmcodewhale0.8.64GHSA-wrj3-vj8c-784f
npmdeepseek-tui0.8.41GHSA-wrj3-vj8c-784f

Affected products (as reported)

VendorProductVersions
Hmbown CodeWhale 0.8.33 – before 0.8.41
Hmbown CodeWhale 0.8.33 – before 0.8.41
Hmbown CodeWhale 0.8.41 – before 0.8.64
Hmbown CodeWhale 0.8.41 – before 0.8.64

Weakness: CWE-94 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

References