Vulnerability · Published Aug 18, 2026 · Assigned by VulnCheck
CVE-2026-75845ArcadeDB 26.4.2 before 26.8.1 Authorization Bypass via set_server_setting
Medium 6.3
In plain English
A medium-severity privilege mismanagement in arcadedb from ArcadeData. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 21% of all known vulnerabilities).
Official description
ArcadeDB versions 26.4.2 through 26.7.3 contain an authorization bypass vulnerability in the set_server_setting MCP server-level tool. SetServerSettingTool.execute() gates only on the global allowAdmin flag and never checks the caller's role, so in an MCP deployment with allowAdmin=true and a non-root allowedUsers set, any authenticated read-only user can invoke set_server_setting to modify server GlobalConfiguration, enabling configuration tampering or denial of service. The issue is fixed in 26.8.1.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| ArcadeData | arcadedb | 26.4.2 – before 26.8.1 |
Weakness: CWE-269 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
References
- GitHub Security Advisory (GHSA-pff6-hp53-pj54) vendor-advisory
- VulnCheck Advisory: ArcadeDB 26.4.2 before 26.8.1 Authorization Bypass via set_server_setting third-party-advisory