Vulnerability · Published May 12, 2026 · Assigned by HashiCorp
CVE-2026-7474Nomad vulnerable to path traversal in dynamic host volume which may lead to code execution
High 8.8
In plain English
A high-severity path traversal in Nomad from HashiCorp. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 8.2% (higher than 95% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)8.8High
Exploit odds (30 days)8.2%top 5.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
HashiCorp Nomad and Nomad Enterprise prior to 2.0.1 are vulnerable to code execution on the client host through a path traversal attack. This vulnerability (CVE-2026-7474) is fixed in Nomad 2.0.1, 1.11.5 and 1.10.11.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/hashicorp/nomad | 1.11.0-rc.1.0.20260511152149-cd7240c4099a | GHSA-hx53-77qj-8663 |
| Go | github.com/hashicorp/nomad | 1.11.0-rc.1.0.20260511152149-cd7240c4099a | GO-2026-5445 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| HashiCorp | Nomad | 1.10.0 – before 2.0.1 |
| HashiCorp | Nomad Enterprise | 1.10.0 – before 2.0.1 |
Weakness: CWE-22 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H