Vulnerability · Published Aug 13, 2026 · Assigned by GitHub_M

CVE-2026-73558vLLM: Cross-User Data Leak Vulnerability

Medium 5.3

In plain English

A medium-severity integer overflow in vllm from vllm-project. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 36% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)0.4%top 64.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

vLLM is an inference and serving engine for large language models. Prior to 0.27.0, an integer overflow in blockIdx.x * 2 * d in activation_kernels.cu can cause act_and_mul_kernel to consume another batched user's input, allowing a request processed in the same inference batch to receive a partial or complete copy of another user's inference result. This issue is fixed in version 0.27.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIvllm0.27.0GHSA-7m6h-x95x-82q5
PyPIvllm0.27.0PYSEC-2026-3935

Affected products (as reported)

VendorProductVersions
vllm-project vllm < 0.27.0

Weakness: CWE-190 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N

References