Vulnerability · Published Aug 13, 2026 · Assigned by GitHub_M

CVE-2026-73489Russh: Post-auth remote panic via pty-req with more than 130 terminal-mode records

Medium 4.3

In plain English

A medium-severity security flaw in russh from Eugeny. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 39% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.3Medium
Exploit odds (30 days)0.5%top 60.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Russh is a Rust SSH client & server library. Prior to 0.62.4, an authenticated SSH client can cause a denial of service by sending a pty-req channel request with more than 130 terminal-mode records. The parser in russh/src/server/encrypted.rs stores terminal modes in a fixed 130-entry [(Pty::TTY_OP_END, 0); 130] array but continues increasing the mode count, then constructs an out-of-bounds slice and panics before the application pty_request handler runs. The panic terminates the server session task without causing memory corruption. This issue is fixed in version 0.62.4.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:14rust-russh0.64.1-1DEBIAN-CVE-2026-73489

Affected products (as reported)

VendorProductVersions
Eugeny russh < 0.62.4

Weakness: CWE-129 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L

References