Vulnerability · Published Aug 12, 2026 · Assigned by GitHub_M

CVE-2026-73418NextAuth.js: getToken() throws an uncaught exception on malformed Bearer authorization headers

High 7.5

In plain English

A high-severity improper input validation in core from @auth. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 59% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.9%top 40.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

NextAuth.js provides authentication for Next.js. Prior to @auth/core 0.41.3 and next-auth 4.24.15 and 5.0.0-beta.32, the exported getToken() helper in the next-auth/jwt and @auth/core/jwt modules can throw an uncaught exception when it reads a malformed Authorization: Bearer header. When no session cookie is present, getToken() URL-decodes the bearer value before validating it, and malformed percent encoding causes decodeURIComponent() to throw instead of treating the token as invalid. Because getToken() is commonly called in API routes, middleware, and server-side request handlers, a single unauthenticated request can trigger an unhandled exception in code paths that authenticate requests, causing a per-request denial of service without exposing tokens, sessions, or other data and without bypassing authentication. This issue is fixed in @auth/core 0.41.3 and next-auth 4.24.15 and 5.0.0-beta.32.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@auth/core0.41.3GHSA-xmf8-cvqr-rfgj
npmnext-auth5.0.0-beta.32GHSA-xmf8-cvqr-rfgj
npmnext-auth4.24.15GHSA-xmf8-cvqr-rfgj

Affected products (as reported)

VendorProductVersions
nextauthjs next-auth >= 4.0.6, <= 4.24.14>= 5.0.0-beta.0, <= 5.0.0-beta.31
@auth core >= 0.1.0, < 0.41.3

Weakness: CWE-20, CWE-248 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References