Vulnerability · Published Aug 20, 2026 · Assigned by GitHub_M
CVE-2026-73258Mongoose: Multipart boundary/header scan logic error in mg_http_next_multipart
Medium 6.5
In plain English
A medium-severity security flaw in mongoose from cesanta. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 40% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Mongoose is an embedded web server and network library. Prior to 7.22, a remote attacker can place a lone carriage return or line feed in multipart input processed by mg_http_next_multipart() in src/http.c. The loops comparing s[b] and s[b + 1], and s[h2] and s[h2 + 1], use an incorrect AND condition and stop when either character resembles part of a CRLF terminator. This truncates headers, filenames, or boundaries and can cause an application to accept dangerous content after seeing a misleading Content-Type value. This issue is fixed in version 7.22.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:14 | mongoose | 7.22+ds-1 | DEBIAN-CVE-2026-73258 |
| Ubuntu:26.10 | mongoose | no fix listed | UBUNTU-CVE-2026-73258 |
Affected products (as reported)
Weakness: CWE-697 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
References
- https://github.com/cesanta/mongoose/security/advisories/GHSA-cc55-8v3r-59p8 x_refsource_CONFIRM
- https://github.com/cesanta/mongoose/pull/3611 x_refsource_MISC
- https://github.com/cesanta/mongoose/commit/a9df523f76f43a38bd53b4232b9cfd4c16869e71 x_refsource_MISC
- https://github.com/cesanta/mongoose/releases/tag/7.22 x_refsource_MISC