Vulnerability · Published Aug 20, 2026 · Assigned by GitHub_M

CVE-2026-73255Mongoose: Path traversal in SSI #include directives enables arbitrary file read

Medium 6.5

In plain English

A medium-severity path traversal in mongoose from cesanta. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 52% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)0.7%top 48.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Mongoose is an embedded web server and network library. Prior to 7.22, an attacker who can control an SSI-enabled file can place directory traversal sequences in an #include file or #include virtual directive. The mg_ssi() function in src/ssi.c concatenates the directive argument into a filesystem path without calling mg_path_is_sane(), allowing an MG_ENABLE_SSI deployment with ssi_pattern configured to disclose files readable by the Mongoose process. This issue is fixed in version 7.22.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:14mongoose7.22+ds-1DEBIAN-CVE-2026-73255
Ubuntu:26.10mongooseno fix listedUBUNTU-CVE-2026-73255

Affected products (as reported)

VendorProductVersions
cesanta mongoose < 7.22

Weakness: CWE-22 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

References