Vulnerability · Published Aug 11, 2026 · Assigned by GitHub_M
CVE-2026-73226Electerm WebSocket `upgrade-func` and `fs` handlers allow arbitrary method/function invocation due to missing method-name allowlist
High 8.8
In plain English
A high-severity security flaw in electerm from electerm. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 55% of all known vulnerabilities).
Official description
electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. Prior to 3.15.186, electerm allows an authenticated WebSocket client to invoke unintended internal functions through client-controlled func values in upgrade-func in src/app/server/dispatch-center.js and handleFs in src/app/server/fs.js, exposing Upgrade and fsExport methods that can execute commands, open files, mutate the filesystem, or terminate the process. This issue is fixed in version 3.15.186.
Affected products (as reported)
Weakness: CWE-913 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
References
- https://github.com/electerm/electerm/security/advisories/GHSA-8chw-jwc5-8587 x_refsource_CONFIRM
- https://github.com/electerm/electerm/pull/4447 x_refsource_MISC
- https://github.com/electerm/electerm/commit/b1729eb67a4cd9cf1182de69dc2c8e051931740f x_refsource_MISC
- https://github.com/electerm/electerm/releases/tag/v3.15.186 x_refsource_MISC