Vulnerability · Published Aug 25, 2026 · Assigned by apache

CVE-2026-73180Apache Tomcat: Authenticated WebSocket session survives end of HTTP session

Medium 6.8

In plain English

A medium-severity security flaw in Apache Tomcat from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 39% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.8Medium
Exploit odds (30 days)0.4%top 61.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Insufficient Session Expiration vulnerability in Apache Tomcat meant that if the session ID for an authenticated HTTP session was changed after a WebSocket connection had been established under that authenticated HTTP session, the WebSokcet session would not be closed as required by the Jakarta WebSocket specification when the HTTP session ended. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.0.M1 through 9.0.120. The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.43 through 7.0.109. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12tomcat10no fix listedDEBIAN-CVE-2026-73180
Debian:13tomcat10no fix listedDEBIAN-CVE-2026-73180
Debian:14tomcat1010.1.60-1DEBIAN-CVE-2026-73180
Debian:13tomcat11no fix listedDEBIAN-CVE-2026-73180
Debian:14tomcat11no fix listedDEBIAN-CVE-2026-73180
Debian:12tomcat99.0.70-2DEBIAN-CVE-2026-73180
Debian:13tomcat99.0.70-2DEBIAN-CVE-2026-73180
Debian:14tomcat99.0.70-2DEBIAN-CVE-2026-73180
Ubuntu:24.04:LTStomcat10no fix listedUBUNTU-CVE-2026-73180
Ubuntu:26.04:LTStomcat10no fix listedUBUNTU-CVE-2026-73180
Ubuntu:26.10tomcat10no fix listedUBUNTU-CVE-2026-73180
Ubuntu:26.04:LTStomcat11no fix listedUBUNTU-CVE-2026-73180
Ubuntu:26.10tomcat11no fix listedUBUNTU-CVE-2026-73180
Ubuntu:24.04:LTStomcat9no fix listedUBUNTU-CVE-2026-73180
Ubuntu:26.04:LTStomcat9no fix listedUBUNTU-CVE-2026-73180
Ubuntu:26.10tomcat9no fix listedUBUNTU-CVE-2026-73180

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Tomcat 11.0.0-M1 – through 11.0.2410.1.0-M1 – through 10.1.579.0.0.M1 – through 9.0.1208.5.0 – through 8.5.1007.0.43 – through 7.0.109

Weakness: CWE-613 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N

References