Vulnerability · Published Aug 11, 2026 · Assigned by GitHub_M
CVE-2026-73077Vim: Arbitrary Code Execution via Shell Keyword Lookup
High 8.4
In plain English
A high-severity OS command injection in vim from vim. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 4% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Vim is an open source, command line text editor. Prior to 9.2.0839, the runtime/ftplugin/sh.vim, runtime/ftplugin/zsh.vim, and runtime/ftplugin/ps1.vim filetype plugins pass attacker-controlled Visual-mode selections from K through keywordprg commands without safely separating shell arguments. fnameescape() and PATH_ESC_CHARS do not neutralize shell metacharacters before ShKeywordPrg, ZshKeywordPrg, or GetHelp invokes bash, zsh, or PowerShell, allowing arbitrary operating-system commands to execute with the privileges of the user running Vim. This issue is fixed in version 9.2.0839.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:10 | vim-X11 | 2:9.1.083-9.el10_2.20 | ALSA-2026:66336 |
| AlmaLinux:9 | vim-X11 | 2:8.2.2637-26.el9_8.21 | ALSA-2026:66366 |
| AlmaLinux:10 | vim-common | 2:9.1.083-9.el10_2.20 | ALSA-2026:66336 |
| AlmaLinux:9 | vim-common | 2:8.2.2637-26.el9_8.21 | ALSA-2026:66366 |
| AlmaLinux:10 | vim-data | 2:9.1.083-9.el10_2.20 | ALSA-2026:66336 |
| AlmaLinux:10 | vim-enhanced | 2:9.1.083-9.el10_2.20 | ALSA-2026:66336 |
| AlmaLinux:9 | vim-enhanced | 2:8.2.2637-26.el9_8.21 | ALSA-2026:66366 |
| AlmaLinux:10 | vim-filesystem | 2:9.1.083-9.el10_2.20 | ALSA-2026:66336 |
| AlmaLinux:9 | vim-filesystem | 2:8.2.2637-26.el9_8.21 | ALSA-2026:66366 |
| AlmaLinux:10 | vim-minimal | 2:9.1.083-9.el10_2.20 | ALSA-2026:66336 |
| AlmaLinux:9 | vim-minimal | 2:8.2.2637-26.el9_8.21 | ALSA-2026:66366 |
| AlmaLinux:10 | xxd | 2:9.1.083-9.el10_2.20 | ALSA-2026:66336 |
| Alpine:v3.23 | vim | 9.2.0854-r0 | ALPINE-CVE-2026-73077 |
| Alpine:v3.24 | vim | 9.2.0843-r0 | ALPINE-CVE-2026-73077 |
| Debian:12 | vim | no fix listed | DEBIAN-CVE-2026-73077 |
| Debian:13 | vim | 2:9.1.1230-2+deb13u1 | DEBIAN-CVE-2026-73077 |
| Debian:14 | vim | 2:9.2.0858-1 | DEBIAN-CVE-2026-73077 |
| Rocky Linux:10 | vim | 2:9.1.083-9.el10_2.20 | RLSA-2026:66336 |
| Rocky Linux:9 | vim | 2:8.2.2637-26.el9_8.21 | RLSA-2026:66366 |
| Ubuntu:22.04:LTS | vim | 2:8.2.3995-1ubuntu2.35 | USN-8657-1 |
| Ubuntu:22.04:LTS | vim | 2:8.2.3995-1ubuntu2.35 | UBUNTU-CVE-2026-73077 |
| Ubuntu:24.04:LTS | vim | 2:9.1.0016-1ubuntu7.19 | UBUNTU-CVE-2026-73077 |
| Ubuntu:24.04:LTS | vim | 2:9.1.0016-1ubuntu7.19 | USN-8657-1 |
| Ubuntu:26.04:LTS | vim | 2:9.1.2141-1ubuntu4.8 | USN-8657-1 |
| Ubuntu:26.04:LTS | vim | 2:9.1.2141-1ubuntu4.8 | UBUNTU-CVE-2026-73077 |
Affected products (as reported)
Weakness: CWE-78 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
References
- https://github.com/vim/vim/security/advisories/GHSA-r5v6-q6j8-8qw2 x_refsource_CONFIRM
- https://github.com/vim/vim/commit/c5a82fe013e73c98004ad7cd4f906b1ad1ed610e x_refsource_MISC