Vulnerability · Published Aug 11, 2026 · Assigned by GitHub_M

CVE-2026-73075Vim: Out-of-bounds Access in Popup Opacity Handling

Medium 4.6

In plain English

A medium-severity out-of-bounds read in vim from vim. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 1% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)4.6Medium
Exploit odds (30 days)<0.1%top 99.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Vim is an open source, command line text editor. From 9.2.0469 until 9.2.0843, popup_mark_opacity_zindex() in src/popupwin.c can use a negative w_winrow for a text-property-anchored popup with clipwindow and opacity, indexing before the screen array instead of accounting for w_popup_topoff and causing an out-of-bounds read and conditional write. This issue is fixed in version 9.2.0843.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.23vim9.2.0854-r0ALPINE-CVE-2026-73075
Alpine:v3.24vim9.2.0843-r0ALPINE-CVE-2026-73075
Debian:14vim2:9.2.0858-1DEBIAN-CVE-2026-73075
Ubuntu:22.04:LTSvimno fix listedUBUNTU-CVE-2026-73075
Ubuntu:24.04:LTSvimno fix listedUBUNTU-CVE-2026-73075
Ubuntu:26.04:LTSvimno fix listedUBUNTU-CVE-2026-73075

Affected products (as reported)

VendorProductVersions
vim vim >= 9.2.0469, < 9.2.0843

Weakness: CWE-124, CWE-125 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N

References