Vulnerability · Published Aug 11, 2026 · Assigned by VulnCheck
CVE-2026-72765n8n before 2.32.1 Remote Code Execution via Expression Sandbox Escape
High 8.7
In plain English
A high-severity code injection in n8n from n8n-io. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 59% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
n8n before 2.31.5 and before 2.32.1 contain a sandbox escape vulnerability in expression evaluation. An authenticated user with permission to create or modify workflows can craft expressions using arrow-function bodies to bypass the expression sandbox, triggering system command execution on the host running n8n. The issue is fixed in versions 2.31.5 and 2.32.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | n8n | 2.32.1 | GHSA-gv7g-jm28-cr3m |
| npm | n8n | 2.31.5 | GHSA-gv7g-jm28-cr3m |
Affected products (as reported)
Weakness: CWE-94 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
References
- GitHub Security Advisory (GHSA-gv7g-jm28-cr3m) vendor-advisory
- VulnCheck Advisory: n8n before 2.32.1 Remote Code Execution via Expression Sandbox Escape third-party-advisory