Vulnerability · Published Aug 6, 2026 · Assigned by GitHub_M

CVE-2026-71436Mermaid XY Charts are vulnerable to an infinite loop DoS

Medium 5.3

In plain English

A medium-severity infinite loop in mermaid from mermaid-js. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)5.3Medium
Exploit odds (30 days)0.6%top 52.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Mermaid is a JavaScript tool that uses Markdown-inspired text to create and modify diagrams and charts. From version 10.6.0 until 10.9.8 and 11.16.1, Mermaid XY Charts are vulnerable to an infinite loop denial of service in the setXAxisRangeData function when configuring an X-Axis with invalid parameters. Because each loop iteration appends an element to an array, this generally causes a RangeError to appear after a few seconds, but it may instead cause the page or JavaScript process to crash from memory exhaustion, depending on the environment. This issue is fixed in versions 10.9.8 and 11.16.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:14node-mermaidno fix listedDEBIAN-CVE-2026-71436
Ubuntu:22.04:LTSnode-mermaidno fix listedUBUNTU-CVE-2026-71436
Ubuntu:26.10node-mermaidno fix listedUBUNTU-CVE-2026-71436
npmmermaid10.9.8GHSA-2v8p-3f2j-5mp7
npmmermaid11.16.1GHSA-2v8p-3f2j-5mp7

Affected products (as reported)

VendorProductVersions
mermaid-js mermaid >= 10.6.0, < 10.9.8>= 11.0.0-alpha.1, < 11.16.1

Weakness: CWE-835, CWE-1325 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:L

References