Vulnerability · Published Aug 5, 2026 · Assigned by GitHub_M
CVE-2026-70600Electron: Cross-origin iframe can position native autofill popup
Low 3.1
In plain English
A low-severity security flaw in electron from electron. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 7% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Electron is a framework for writing cross-platform desktop applications using JavaScript, HTML and CSS. Prior to 39.8.8, 40.9.0, 41.2.1, and 42.0.0-beta.3, the native autofill popup could be positioned by a cross-origin iframe outside that iframe's bounds, over the embedding page's UI, enabling clickjacking or spoofing of trusted UI. Apps are only affected if they embed untrusted content in iframes within windows that also display trusted UI. Apps that do not embed untrusted third-party content are not affected. This issue is fixed in versions 39.8.8, 40.9.0, 41.2.1, and 42.0.0-beta.3.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | electron | 39.8.8 | GHSA-x8rc-wpg4-grpf |
| npm | electron | 40.9.1 | GHSA-x8rc-wpg4-grpf |
| npm | electron | 41.2.1 | GHSA-x8rc-wpg4-grpf |
| npm | electron | 42.0.0-beta.3 | GHSA-x8rc-wpg4-grpf |
Affected products (as reported)
Weakness: CWE-1021 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N
References
- https://github.com/electron/electron/security/advisories/GHSA-x8rc-wpg4-grpf x_refsource_CONFIRM