Vulnerability · Published Aug 4, 2026 · Assigned by GitHub_M

CVE-2026-70477Flowise: CSV Agent Prompt Injection Remote Code Execution Vulnerability

Critical 9.5

In plain English

A critical-severity code injection in Flowise from FlowiseAI. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 57% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)9.5Critical
Exploit odds (30 days)0.8%top 42.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.3, a prompt injection sent to a chatflow using a CSV Agent node can cause the LLM to respond with a malicious Python script that bypasses the blocklist validator and executes in an unsandboxed Pyodide environment. The specific flaw exists within the run method of the CSV_Agents class, where untrusted data is used to construct an LLM prompt and the resulting pythonCode is validated by validatePythonCodeForDataFrame before execution. An attacker can leverage this to execute arbitrary code in the context of the service account. This issue is fixed in 3.1.3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmflowise3.1.3GHSA-5xvg-pmgg-3mxr
npmflowise-components3.1.3GHSA-5xvg-pmgg-3mxr

Affected products (as reported)

VendorProductVersions
FlowiseAI Flowise < 3.1.2

Weakness: CWE-94 · Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

References