Vulnerability · Published Aug 3, 2026 · Assigned by GitHub_M

CVE-2026-69248python-cryptography verifier accepts wildcard DNS names allowing escape from permittedSubtrees

Medium 6.9

In plain English

A medium-severity improper certificate validation in cryptography from pyca. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 16% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)6.9Medium
Exploit odds (30 days)0.2%top 84.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

cryptography is a package designed to expose cryptographic primitives and recipes to Python developers. In versions 45.0.0 through 48.0.0, if an intermediate constrained CA permits the DNS name foo.example.com, and the leaf certificate has a wildcard in its DNS SAN of *.example.com, python-cryptography's verifier accepts which allows escaping outside of the permitted names. The core issue is in DNSConstraint::matches, where a wildcard pattern was treated as matching a more-specific permitted constraint even though *.example.com can expand to sibling names such as bar.example.com outside foo.example.com. This allows acceptance of an invalid certificate chain. This issue is fixed in 49.0.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:10python3.14-cryptography45.0.4-4.el10_2.5ALSA-2026:64795
AlmaLinux:9python3.14-cryptography45.0.4-4.el9_8.6ALSA-2026:64774
Debian:12python-cryptographyno fix listedDEBIAN-CVE-2026-69248
Debian:13python-cryptographyno fix listedDEBIAN-CVE-2026-69248
Debian:14python-cryptography49.0.0-1DEBIAN-CVE-2026-69248
PyPIcryptography49.0.0PYSEC-2026-3554
PyPIcryptography49.0.0GHSA-m2h6-j472-rp4c
Rocky Linux:10python3.14-cryptography0:45.0.4-4.el10_2.5RLSA-2026:64795
Rocky Linux:9python3.14-cryptography0:45.0.4-4.el9_8.6RLSA-2026:64774
Ubuntu:26.04:LTSpython-cryptography46.0.5-1ubuntu2.2UBUNTU-CVE-2026-69248
Ubuntu:26.04:LTSpython-cryptography46.0.5-1ubuntu2.2USN-8776-1

Affected products (as reported)

VendorProductVersions
pyca cryptography < 49.0.0

Weakness: CWE-295 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:H/VA:N/SC:N/SI:N/SA:N/E:P

References