Vulnerability · Published Aug 3, 2026 · Assigned by GitHub_M

CVE-2026-69185Socket.IO: Zero-attachment Memory Exhaustion

High 7.5

In plain English

A high-severity improper input validation in socket.io from socketio. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 50% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.6%top 49.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Socket.IO enables bidirectional and low-latency communication for every platform. Prior to 4.2.7, 3.4.5, and 3.3.6, a specially crafted Socket.IO packet can make the server wait for a large number of binary attachments and buffer them, which can be exploited to make the server run out of memory. This vulnerability is fixed in 4.2.7, 3.4.5, and 3.3.6.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12node-socket.io-parserno fix listedDEBIAN-CVE-2026-69185
Debian:13node-socket.io-parserno fix listedDEBIAN-CVE-2026-69185
Debian:14node-socket.io-parser4.2.4+~3.1.2-1DEBIAN-CVE-2026-69185
Ubuntu:22.04:LTSnode-socket.io-parserno fix listedUBUNTU-CVE-2026-69185
Ubuntu:24.04:LTSnode-socket.io-parserno fix listedUBUNTU-CVE-2026-69185
Ubuntu:26.04:LTSnode-socket.io-parserno fix listedUBUNTU-CVE-2026-69185
Ubuntu:26.10node-socket.io-parserno fix listedUBUNTU-CVE-2026-69185
npmsocket.io-parser4.2.7GHSA-2m8v-j782-fhvr
npmsocket.io-parser3.4.5GHSA-2m8v-j782-fhvr
npmsocket.io-parser3.3.6GHSA-2m8v-j782-fhvr

Affected products (as reported)

VendorProductVersions
socketio socket.io < 3.3.6>= 3.4.0, < 3.4.5>= 4.0.0, < 4.2.7

Weakness: CWE-20, CWE-754 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References