Vulnerability · Published Aug 3, 2026 · Assigned by GitHub_M

CVE-2026-69151Angular i18n: Cross-Site Scripting (XSS) via event-handler attributes

High 7.6

In plain English

A high-severity cross-site scripting in angular from angular. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 27% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)7.6High
Exploit odds (30 days)0.3%top 73.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 20.3.27, 21.2.19, and 22.0.1, the Angular compiler i18n pipeline permits i18n-onerror and other i18n-on event-handler attributes, allowing a lower-trust translation file to replace a static handler with executable JavaScript. This issue is fixed in versions 20.3.27, 21.2.19, and 22.0.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12angular.jsno fix listedDEBIAN-CVE-2026-69151
Debian:13angular.jsno fix listedDEBIAN-CVE-2026-69151
Ubuntu:22.04:LTSangular.jsno fix listedUBUNTU-CVE-2026-69151
Ubuntu:24.04:LTSangular.jsno fix listedUBUNTU-CVE-2026-69151
Ubuntu:26.04:LTSangular.jsno fix listedUBUNTU-CVE-2026-69151
Ubuntu:26.10angular.jsno fix listedUBUNTU-CVE-2026-69151
npm@angular/compiler21.2.19GHSA-jj27-h5hq-8x99
npm@angular/compiler22.0.1GHSA-jj27-h5hq-8x99
npm@angular/compiler20.3.27GHSA-jj27-h5hq-8x99
npm@angular/compilerno fix listedGHSA-jj27-h5hq-8x99
npm@angular/core22.0.1GHSA-jj27-h5hq-8x99
npm@angular/core21.2.19GHSA-jj27-h5hq-8x99
npm@angular/core20.3.27GHSA-jj27-h5hq-8x99
npm@angular/coreno fix listedGHSA-jj27-h5hq-8x99

Affected products (as reported)

VendorProductVersions
angular angular >= 22.0.0-next.0, < 22.0.1>= 21.0.0-next.0, < 21.2.19< 20.3.27
@angular compiler >= 22.0.0-next.0, < 22.0.1>= 21.0.0-next.0, < 21.2.19< 20.3.27
@angular core >= 22.0.0-next.0, < 22.0.1>= 21.0.0-next.0, < 21.2.19< 20.3.27

Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

References