Vulnerability · Published Aug 7, 2026 · Assigned by GitHub_M

CVE-2026-69127Kirby: System path exposure from error messages in the REST API

Medium 6.9

In plain English

A medium-severity security flaw in kirby from getkirby. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 53% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)6.9Medium
Exploit odds (30 days)0.7%top 46.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Kirby is an open-source content management system. Prior to 4.9.5 and from 5.0.0 through 5.5.1, the REST API error handler can return unsanitized PHP error messages that expose the full filesystem path of the Kirby installation to unauthenticated API users. This vulnerability affects all Kirby sites that have not disabled the REST API with the 'api' => false option. This issue is fixed in versions 4.9.5 and 5.5.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistgetkirby/cms4.9.5GHSA-rf2p-vh74-7vvh
Packagistgetkirby/cms5.5.2GHSA-rf2p-vh74-7vvh

Affected products (as reported)

VendorProductVersions
getkirby kirby < 4.9.5>= 5.0.0, < 5.5.2

Weakness: CWE-497 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

References